Drush command not working

by Sue   Last Updated September 13, 2017 14:07 PM

I am working on MAMP and I have already installed a drupal7 site in my local machine ( not using drush or composer ). Then I have installed composer and drush ( https://www.bramvandenbulcke.be/en/article/installing-drush-mamp ). Now my Drupal site is under htdocs folder and its working. If I run "drush" from htdocs via command line then it's shown a bunch of help command list.

But if I am trying to install any module using drush dl Module_Name then its give me an error

" [error] dl has been deprecated. Please build your site using Composer. Add new projects with composer require drupal/[project-name]. Use https://www.drupal.org/project/composer_generate to build a composer.json which represents the the enabled modules on your site. "

Can anyone plz tell me whats the problem? Do I need to install a fresh Drupal 7 site via composer?

Thanks Sue

Tags : drush composer


Related Questions


drush 7.3 is not working

Updated July 16, 2016 08:03 AM

Freshly installed Drush is unresponsive

Updated May 12, 2016 08:03 AM

How to install drush 8 properly on Debian 8?

Updated June 16, 2015 03:03 AM

Add/Fix composer in an ongoing project

Updated June 07, 2017 09:07 AM