Postgresql equivalent of --i-am-a-dummy

by ldrg   Last Updated September 11, 2019 21:06 PM

MySQL's command line tool has a flag --i-am-a-dummy that sets execution limits:

With --safe-updates, you can modify rows only by specifying the key values that identify them, or a LIMIT clause, or both. This helps prevent accidents. Safe-updates mode also restricts SELECT statements that produce (or are estimated to produce) very large result sets.

Is there a way to turn on similar features in psql?

Tags : postgresql psql


Related Questions



Safe way to perform DB script

Updated May 08, 2015 12:08 PM


PSQL want to use italy utf8

Updated May 19, 2015 01:02 AM