SSRS 2016 - Client found response content type of '', but expected 'text/xml'

by SomeGuy   Last Updated July 12, 2019 22:06 PM

I've got SQL Server 2017 Developer installed on my workstation, and just installed SSRS 2017. I am able to navigate in the SSRS portal, and upload files of dummy data, and create KPIs. However, when click "+New", then "Dataset" or "Data Source", I get the message "Something went wrong. Please try again later." The only clue in a log file is in my RSPortal_yyyy_mm_dd......log file which shows the following:

OData exception occurred: Microsoft.SqlServer.ReportingServices2010.RSConnection2010+MissingEndpointException: The attempt to connect to the report server failed. Check your connection information and that the report server is a compatible version. ---> System.InvalidOperationException: Client found response content type of '', but expected 'text/xml'

I get the same error if trying to upload an .rdl file.

I did a "next/next/next" install of SSRS, keeping the defaults. The only unusual thing is that I am logged in with a machine account, not a user account. This machine account does show in the top right corner of the SSRS web portal, so that is passing through at least.

What could be happening here?



Related Questions



Making Switches Work in SSRS

Updated February 08, 2018 18:06 PM

SSRS Label Orientation

Updated August 14, 2018 18:06 PM

SSRS Reports Blank on Zebra Printer

Updated August 23, 2018 20:06 PM

Catch SqlException on SSRS report

Updated October 24, 2017 21:06 PM