Why is the sitemap validator returning an error for the lastmod tag?

by Anish Kuriakose   Last Updated January 23, 2018 10:04 AM

The sitemap of my company's brand's website seems to be fine when I look at it at first glance. I don't particularly see any errors as such. However, SEMrush, the SEO tool, reports that our sitemap is not in the correct format. SEMrush doesn't tell me what's wrong. It just says that the format is incorrect.

So, I submitted the sitemap to this online validator:

https://www.xml-sitemaps.com/index.php?op=validate-xml-sitemap&go=1&sitemapurl=http%3A%2F%2Fwww.photojaanic.com%2Fsitemap.xml&submit=Validate+Sitemap

It says no issues found. But, when I run it through another tool:

http://tools.seochat.com/tools/site-validator/

It returns several errors for the lastmod tags. Here's one of them:

<url><loc>http://www.photojaanic.com/photo-gifts/keychains</loc>
<lastmod>2017-07-24T04:37Z</lastmod><changefreq>yearly</changefreq></url>

Error 1826: Element '{http://www.sitemaps.org/schemas/sitemap/0.9}lastmod':
'2017-07-24T04:37Z' is not a valid value of the union type
'{http://www.sitemaps.org/schemas/sitemap/0.9}tLastmod'. on line: 5 column: 0
Could this be the reason why the sitemap is wrong? I wonder why the date-
time format is wrong.

I also tried another validator. Even that one returns many errors along with the lastmod issue:

http://freetools.webmasterworld.com/tools/site-validator

I'm not so concerned about the other errors as they're related to video or images. That could be rectified. What I'm concerned is about the lastmod tag.

A way to get around the lastmod issue could be to simply exclude the time. However, I'd like to know why there's an error.

Thanks.



Related Questions




Images sitemap not indexed

Updated March 22, 2017 14:04 PM


Images are not indexed in google search console

Updated June 29, 2017 11:04 AM