apt update version mismatch issue

by Mehdi2277   Last Updated August 14, 2019 19:02 PM

Recently, ROS updated the version of some of its packages like python-rospkg. If you check here, http://packages.ros.org/ros/ubuntu/pool/main/p/python-rospkg/, you can see the latest version is 1.1.10. When I try using apt update and then apt install python-rospkg it attempts to get 1.1.9 which no longer exists there and fails. I've double checked and my /etc/apt/sources.list.d/ contains a file for this package repository called ros-latest.list and the file contents look fine,

deb http://packages.ros.org/ros/ubuntu xenial main



Related Questions


KDE "Authentication Errors"

Updated August 08, 2015 22:00 PM

Muon Discover fails to find Wine

Updated September 12, 2015 10:01 AM

How to install Texlive on Kubuntu 15.04 (tar.gz)

Updated September 29, 2015 08:01 AM