ubuntu not updating neither installing anything (Package system is broken)

by Himanshu Patel   Last Updated August 14, 2019 19:02 PM

Check if you are using third party repositories. If so disable them, since they are a common source of problems. Furthermore run the following command in a Terminal: apt-get install -f Transaction failed: The package system is broken The following packages have unmet dependencies:

gdm3: Depends: libaudit1 (>= 1:2.2.1) but 1:2.8.2-1ubuntu1 is installed
      Depends: libgdm1 (= 3.28.3-0ubuntu18.04.4) but 3.28.3-0ubuntu18.04.4 is installed
      Depends: libwrap0 (>= 7.6-4~) but 7.6.q-27 is installed
      Depends: gir1.2-gdm-1.0 (= 3.28.3-0ubuntu18.04.4) but 3.28.3-0ubuntu18.04.3 is installed
      Depends: bash (>= 4.3) but 4.4.18-2ubuntu1.2 is installed
      Depends: x-terminal-emulator but it is a virtual package
      Depends: x11-common (>= 1:7.6+11) but 1:7.7+19ubuntu7.1 is installed
gir1.2-mutter-2: Depends: libmutter-2-0 (= 3.28.4-0ubuntu18.04.1) but 3.28.3-2~ubuntu18.04.2 is installed
gnome-shell: Depends: libgjs0-libmozjs-52-0 but it is a virtual package
             Depends: gir1.2-mutter-2 (>= 3.28.4-0ubuntu18.04.1) but 3.28.4-0ubuntu18.04.1 is installed
             Depends: gnome-shell-common (= 3.28.4-0ubuntu18.04.1) but 3.28.3-0ubuntu0.18.04.4 is installed
             Depends: mutter (>= 3.28.4-0ubuntu18.04.1) but 3.28.3-2~ubuntu18.04.2 is installed
libgl1: Depends: libc6 (>= 2.14) but 2.27-3ubuntu1 is installed
        Depends: libglvnd0 (= 1.0.0-2ubuntu2.3) but 1.0.0-2ubuntu2.2 is installed
        Depends: libglx0 (= 1.0.0-2ubuntu2.3) but 1.0.0-2ubuntu2.2 is installed
policykit-1: Depends: libc6 (>= 2.7) but 2.27-3ubuntu1 is installed
             Depends: libglib2.0-0 (>= 2.37.3) but 2.56.4-0ubuntu0.18.04.4 is installed
             Depends: libpolkit-agent-1-0 (= 0.105-20ubuntu0.18.04.5) but 0.105-20ubuntu0.18.04.4 is installed
             Depends: libpolkit-backend-1-0 (= 0.105-20ubuntu0.18.04.5) but 0.105-20ubuntu0.18.04.4 is installed
             Depends: libpolkit-gobject-1-0 (= 0.105-20ubuntu0.18.04.5) but 0.105-20ubuntu0.18.04.4 is installed


Related Questions


The Package System is Broken

Updated April 06, 2017 23:02 PM


Cant Download anything

Updated March 18, 2017 14:02 PM


How to install GUI desktop on a server?

Updated April 19, 2015 22:01 PM