Computer won't turn on. Is it the motherboard, RAM or CPU?

by James Watt   Last Updated May 17, 2018 19:01 PM

The computer is a Dell Vostro 220 Slim Tower (regular tower.) When the power button is pressed, the computer exhibits the following behavior:

  • No lights turn on
  • No noise is heard
  • No fans turn at all
  • Monitor says "No Signal Connected"

The computer was on an APC battery backup, so this was not caused by an electrical anomaly as far as I know.

What I tried:

  • Replaced power supply
  • Replaced power cord
  • Plugged into completely different outlet (w/o battery backup)

None of these things changed the situation.

Is it the motherboard? Or could it be the RAM/CPU?

Tags : motherboard


Answers 8


I'm pretty sure it's the MB, because CPU problems should make "beep" error sounds. Since you'r not having any "beep" sounds - the MB is the main culprit.

Matan Eldan
Matan Eldan
July 14, 2010 15:21 PM

If absolutely nothing is happening I tend to suspect the mobo because even if there's nothing connected pressing the power switch should send a signal to the PSU that would turn on case fans, etc.

The ram is almost certainly not to blame (although if the mobo failed catastrophically it could have been fried too), because a good board with a working CPU should produce a post error code indicating a ram problem.

Dan Neely
Dan Neely
July 14, 2010 15:22 PM

When you say "replaced power suply" it means that you changed the ATX power supply, doesn't it? Did you correctly connected the wires of ATX power supply? If "yes" and "yes", then the problem must be motherboard.

kokbira
kokbira
July 14, 2010 16:13 PM

Since you have already replaced the power supply, the problem is presumably something that's causing the power supply to shut down the instant you turn it on, The problem could be the motherboard or it could be one of the drives. If you are comfortable working inside the computer, you could try removing the power (and corresponding signal cables to be safe) from any hard drive, CD/DVD drive, etc. (i.e. everything except the motherboard) and see if that makes a difference. On the other hand, the problem could be that the power supply is not being turned on because of a bad power switch, broken wire etc. though this seems less likely.

Paul
Paul
July 14, 2010 17:10 PM

Most (9 out of 10) systems will

  • have a small LED somewhere on the MB that is on when the power is connected (even if the system is powered off).
  • have blinking lights in the (onboard) network adapter if the power is connected and a network cable is attached that is connected to a switch or other system.(even if the system is powered off)
  • make beeping sounds if the memory or cpu is dead... but that does require an old fashion speaker to be attached and only happens iff the system is being powered to boot.

Now because your system apparently does none of this my assessment is that the mainboard is not getting powered. This implies that either

  • your mainboard is seriously broken (which may also cause the next item on my list).
  • your power switch (the signal goes through the mainboard !!) is broken (or connected badly to the mainboard) --> the power supply simply doesn't receive the signal to start powering the system.
  • your power supply is not sending power (i.e. dead or not started)
  • or the connection between the two is dead. (i.e. check all connectors).
Niels Basjes
Niels Basjes
July 14, 2010 17:41 PM

I'm posting this answer for people who have similar problems. I recently had the same problem and it seems to have turned out that scratches on the place where you place the motherboard was causing a short which prevented boot.

indyK1ng
indyK1ng
August 16, 2010 20:45 PM

i had issues since wednesday with my new M5a97 and FX-8320 , no vga output no indication of anything working except fans and a few lights, it turned out one of my ram's is broken or misfunctioning i tryed both on all possible configurations, and turned out one worked and the other didnt. at first i thought it had to do with the nw mobo and new cpu. then i thought it was my older vid card and my even older psu.. turned to be one of the new ram's

so my advice, try the ram on any possible way, just one. slot 1 - 2- 3 -4 etc took me a day but now its now booting!

mark
mark
November 16, 2013 15:12 PM

If the symptoms are such that nothing at all happens when you press the power button, it may be as simple as a dead CMOS battery (the CR2032 button cell on the motherboard). Yes. Really. That simple.

I know this because it just happened to me on a "vintage" PIII system I was preparing. Not thinking it could be the CMOS battery (I've encountered dozens of machines with dead CMOS that work fine, except for thinking its 1999), I did the obligatory PSU "paperclip" test followed by multimeter testing the power switch and cable. They were all fine. The battery wasnt. I Replaced it. Everything works.

Really. Check the battery.

starfry
starfry
May 17, 2018 18:58 PM

Related Questions


intel DG41RQ motherboard is not booting

Updated March 28, 2015 14:00 PM

New mother board....operating system not found

Updated April 21, 2015 02:00 AM


Can I use a jumper in place of an on/off switch?

Updated June 30, 2015 20:00 PM

Intel DG33BU 3 Beeps

Updated April 26, 2015 00:00 AM