Ganache GUI installation error

by Darshan   Last Updated August 14, 2019 13:28 PM

node version v12.8.0,npm version 6.10.2

I followed the below steps to install the ganache GUI but I got the error

$mkdir ~/ganache
$git clone https://github.com/trufflesuite/ganache.git
$npm install
$npm start

error:

[email protected] start /home/nithin/ganache electron-forge start

✔ Checking your system
✔ Locating Application

An unhandled rejection has occurred inside Forge:
Could not determine Electron version. Make sure that 'npm install' (or 'yarn') has been run before invoking electron-forge.
Error: Could not determine Electron version. Make sure that 'npm install' (or 'yarn') has been run before invoking electron-forge.
at /usr/lib/node_modules/electron-forge/dist/util/rebuild.js:26:13
at Generator.next (<anonymous>)
at Generator.tryCatcher (/usr/lib/node_modules/electron-forge/node_modules/bluebird/js/release/util.js:16:23)
at PromiseSpawn._promiseFulfilled (/usr/lib/node_modules/electron-forge/node_modules/bluebird/js/release/generators.js:97:49)
at /usr/lib/node_modules/electron-forge/node_modules/bluebird/js/release/generators.js:201:15
at /usr/lib/node_modules/electron-forge/dist/util/rebuild.js:63:17
at /usr/lib/node_modules/electron-forge/dist/api/start.js:105:33
at Generator.next (<anonymous>)
at Generator.tryCatcher (/usr/lib/node_modules/electron-forge/node_modules/bluebird/js/release/util.js:16:23)
at PromiseSpawn._promiseFulfilled (/usr/lib/node_modules/electron-forge/node_modules/bluebird/js/release/generators.js:97:49)
at Promise._settlePromise (/usr/lib/node_modules/electron-forge/node_modules/bluebird/js/release/promise.js:579:26)
at Promise._settlePromise0 (/usr/lib/node_modules/electron-forge/node_modules/bluebird/js/release/promise.js:619:10)
at Promise._settlePromises (/usr/lib/node_modules/electron-forge/node_modules/bluebird/js/release/promise.js:699:18)
at _drainQueueStep (/usr/lib/node_modules/electron-forge/node_modules/bluebird/js/release/async.js:138:12)
at _drainQueue (/usr/lib/node_modules/electron-forge/node_modules/bluebird/js/release/async.js:131:9)
at Async._drainQueues (/usr/lib/node_modules/electron-forge/node_modules/bluebird/js/release/async.js:147:5)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] start: `electron-forge start`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the [email protected] start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/nithin/.npm/_logs/2019-08-14T11_24_08_546


Related Questions



problem of call() returns null

Updated May 13, 2019 06:28 AM

Web3 server-side trouble connect with ganache

Updated August 01, 2018 14:28 PM

Cannot access ganche using web3js from remote device

Updated January 11, 2019 15:28 PM