VS code Expected identifier, got 'LParen'solc

by João Quintanilha   Last Updated August 14, 2019 09:28 AM

I keep getting this error/warning on my vscode when I emit events and build constructors.

enter image description here

or

enter image description here

After a bit of googling I understand it is something about my compiler, since solc <0.4.18 does not support these features. This thread says I have to update truffle to fix this problem. Although, I'm not using truffle at all. I have

"solidity.compileUsingRemoteVersion": "v0.4.25+commit.59dbf8f1",

on my vscode settings and on my terminal I have

> $ solc --version 
> Version: 0.4.25+commit.59dbf8f1.Linux.g++

Would appreciate any help.



Related Questions


VS Code and Solidity files have a lot of warnings

Updated August 13, 2019 17:28 PM


Error when calling the selfdistruct method in solidity

Updated December 13, 2018 21:28 PM