dependency error in android studio= com.android.support:appcompat-v7:29.+

by user11928334   Last Updated August 14, 2019 18:26 PM

I am getting this dependency error in Android Studio, how can I fix it?

Unable to resolve dependency for ':[email protected]/compileClasspath': Could not find any version that matches com.android.support:appcompat-v7:29.+.
<a href="openFile:C:/Users/Don&#39;t U DArE/AndroidStudioProjects/1stApp/app/build.gradle">Open File</a><br><a href="Unable to resolve dependency for &#39;:[email protected]/compileClasspath&#39;: Could not find any version that matches com.android.support:appcompat-v7:29.+.">Show Details</a>   
Unable to resolve dependency for ':[email protected]/compileClasspath': Could not find any version that matches com.android.support:appcompat-v7:29.+.
<a href="openFile:C:/Users/Don&#39;t U DArE/AndroidStudioProjects/1stApp/app/build.gradle">Open File</a><br><a href="Unable to resolve dependency for &#39;:[email protected]/compileClasspath&#39;: Could not find any version that matches com.android.support:appcompat-v7:29.+.">Show Details</a>    
Unable to resolve dependency for ':[email protected]/compileClasspath': Could not find any version that matches com.android.support:appcompat-v7:29.+.
<a href="openFile:C:/Users/Don&#39;t U DArE/AndroidStudioProjects/1stApp/app/build.gradle">Open File</a><br><a href="Unable to resolve dependency for &#39;:[email protected]/compileClasspath&#39;: Could not find any version that matches com.android.support:appcompat-v7:29.+.">Show Details</a>   
Unable to resolve dependency for ':[email protected]/compileClasspath': Could not find any version that matches com.android.support:appcompat-v7:29.+.
<a href="openFile:C:/Users/Don&#39;t U DArE/AndroidStudioProjects/1stApp/app/build.gradle">Open File</a><br><a href="Unable to resolve dependency for &#39;:[email protected]/compileClasspath&#39;: Could not find any version that matches com.android.support:appcompat-v7:29.+.">Show Details</a> 
Unable to resolve dependency for ':[email protected]/compileClasspath': Could not find any version that matches com.android.support:appcompat-v7:29.+.
<a href="openFile:C:/Users/Don&#39;t U DArE/AndroidStudioProjects/1stApp/app/build.gradle">Open File</a><br><a href="Unable to resolve dependency for &#39;:[email protected]/compileClasspath&#39;: Could not find any version that matches com.android.support:appcompat-v7:29.+.">Show Details</a> 


Answers 1


You're trying to use support library version 29 but there is no such version. The latest version is 28.0.0, see Recent Support Library Revisions.

You need to migrate your support library to AndroidX. See Migrating to AndroidX.

ישו אוהב אותך
ישו אוהב אותך
August 14, 2019 18:25 PM

Related Questions