Why is my external hard-drive is not appearing (most of the time)

by jupiar   Last Updated July 11, 2019 02:12 AM

I recently bought an external hard-drive, Western Digital 4GB, and I have a MacBook-pro 2015 (15inch).

When I received the hard-drive, it worked like a dream, I just re-formatted it to apple's file system (non-encrypted). One time the USB cable got accidentally knocked out the left side, and then from then on, if I plugged the hard-drive in the left USB, it wouldn't show up. So I started using the right side USB, no problem. And then a week later, the same thing happened, accidentally knocked the cable out, and from then on, it wouldn't show up.

I have an external USB hub (USB powered), and now that is the only way I can use the external drive, (most of the time), it usually appears with a 1/5 chance, but once appeared, it is stable. This is not due to the USB hub, as I have two other 4TB hard-drives in a 5 bay 3.5" enclosure.

How can I remedy this problem? The drive does not show up in the Disk Utility program, nor does it show up under USB in the System Information program, nor does it show up with $ diskutil list, nor does in show up in /Volumes. I thought it might be a cache problem, maybe Mac does some caching of hard-drives used, etc.., so I removed the cache's from /Library and /System.

I'm a programmer, so any command-line solutions are very welcome.



Related Questions



Which format for external disk for performance?

Updated March 04, 2018 21:12 PM