I have no keyboard!

by Julian   Last Updated June 29, 2018 08:11 AM

I have a 'Rooted Samsung Galaxy Note 10.1 NT-N8000'(tablet) running Unofficial CM 13 Marshmallow 6.0.1 and a TWRP touch recovery. After i flashed cm13 i had no keyboard anymore, so i couldnt login to wifi and login to the google play store... Then i made a free wifi hotspot on my phone and logged in (so i had wifi) so i could use the microphone to search for an app but i needed to login the playstore, i also cant downlaod the app to my tablet from the pc cuz i havent logged in with my google account on my tablet yet. Then i downloaded a keyboard app on my phone, extract it, email it to my computer, on my computer transfer it to an sdcard, and then plugged it in my tablet and installed it... (Pfffff) but it still doesnt work! i tried google keyboard and Chrooma keyboard. NONE work, and the settings are all fine ! Thank you soo much for the help guys!!!

Please help! - Julian



Answers 4


CyanogenMod has a keyboard built in, did you try going to Settings -> Language & Input and make sure you have a keyboard set as "Current Keyboard", the default keyboard in CM is Android Keyboard (AOSP)?

If there is truly no keyboard installed, you can go to http://www.apkmirror.com/ and download any number of keyboards, such as Swiftkey Keyboard or Google Keyboard as examples, then install them manually. You may need to make sure that Unknown Sources is enabled in Settings -> Security

acejavelin
acejavelin
July 01, 2016 15:11 PM

I had the same issue. Just go to the right, choose language, and then you slide "Hardware show input method" to On. Should work.

Leandro
Leandro
September 21, 2016 17:59 PM

I had problems with keyboard on CM13 because of gapps you should delete this file "/system/lib/libjni_latinimegoogle.so" right after flashing ROM and the GAPPS. You can delete it from TWRP's file manager, if you have troubles with deleting or finding file let me know.

Једноруки Крстивоје
Једноруки Крстивоје
September 21, 2016 18:15 PM

if you are installing any custom rom than go for the stock gapps rather than pico or nano stock gapps cover all the google services including keyboard i had the same issue when i have installed ressurection remix with gapps pico but after installing stock gapps the issue was solved ....

user266651
user266651
June 29, 2018 07:35 AM

Related Questions


How to install Cyanogenmod on Xolo Q1010i?

Updated May 25, 2015 22:04 PM

CM13 x86 not rooted?

Updated February 26, 2017 14:11 PM

SuperSu not at all functional, can't uninstall

Updated April 27, 2015 21:04 PM

Low memory message on cm 9.1.0

Updated May 28, 2015 22:04 PM

rename file inside /system with no root access (CM13)

Updated January 02, 2017 08:04 AM