How to mention the magento version compatibility in composer.json

by Sammu Sundar   Last Updated January 11, 2019 11:09 AM

I am creating a module in magento 2 . Now i am writing composer.json . Here i write supporting php version

"require": {
    "php": "~5.6.0|^7.0.0",
  },

How to i write my module will be supported by magento version greater than 2.1 , not support by 2.0

i found

 "magento/framework": "^102.0.0",
"magento/module-backend": "^101.0.0"

What is the meaning of above lines . is it the version of magento? what is 102.0.0 means?



Answers 1


It describe as which Magento framework version.

You can check here more details

https://devdocs.magento.com/guides/v2.3/architecture/archi_perspectives/framework.html

Rohan Hapani
Rohan Hapani
January 11, 2019 11:02 AM

Related Questions



Magento 2: Composer install for my own module

Updated February 25, 2017 13:09 PM

Problem with CLI installing module

Updated September 07, 2018 14:09 PM

Module developement update composer config

Updated April 23, 2016 08:04 AM